Aus den Lexware faktura+auftrag bzw. warenwirtschaft Programmen kann man Aufträge direkt an sein genutztes E-Mail Programm übergeben. In letzter Zeit kommt es gehäuft zu der Meldung Nachricht konnte nicht gesendet werden, gehäuft dann, wenn Windows 10 im Einsatz ist und dort ein Update installiert wurde.

Fehlermeldung / Error

Die Übergabe an das Mailprogramm erfolgt in der Regel problemlos, nur kann dieses die Nachricht nicht versenden. Um den Sachverhalt zu lösen, gibt es verschiedene Lösungsansätze:

  1. MS Outlook ist mehr als einmal und in unterschiedlichen Versionen installiert
  2. das genutzte Mailprogramm ist nicht das Standardmailprogramm auf dem PC
  3. die Installation des genutzten Mailprogramms ist beschädigt
  4. die Datei lxmailcom.dll ist nicht oder nicht mehr korrekt registriert

Lösungswege

Zur Prüfung geht Ihr wie nachstehend beschrieben vor:

Drückt die Tastenkombination WIN (befindet sich in der Regel rechts neben der linken STRG-Taste; mit Windows Logo) und R, also WIN-Taste gedrückt halten und dann R-Taste drücken. Es öffnet sich das Ausführen-Fenster. Dort gebt Ihr appwiz.cpl ein und drückt die Enter-Taste oder Ok beim Ausführen-Fenster. Nun öffnet sich die Liste der installierten Programme. Dieses Fenster lässt sich natürlich auch über den Weg durch die Systemsteuerung -> Programme und Features erreichen.

Prüft in der Liste der installierten Programme bitte, ob Outlook mehr als 1x aufgeführt ist, z.B. Outlook 2013 oder Outlook 2010 oder auch Office 365. Ihr müsste Euch für eine Variante entscheiden. Die nicht benötigte dann bitte deinstallieren. Dazu bitte vorab intern im Unternehmen abstimmen, welche Version firmenseitig zur Nutzung gewünscht ist. In der Regel wird dies vermutlich die neuere Version sein.

Führt dies nicht zur Lösung, prüft bitte, ob das gewünschte Mailprogramm als Standard auf Eurem System eingerichtet ist. Für Windows 7 gibt es hier und für Windows 10 hier eine entsprechende Anleitung. Wenn Ihr Windows 8 nutzt, dann hilft diese Anleitung.

Ist auch das nicht die Lösung, also bleibt es danach weiterhin bei der Meldung, die Nachrichten können nicht versendet werden, bitte eine Reparaturinstallation des jeweiligen Mailprogramms durchführen. Hierzu wie oben beschrieben die Liste der installierten Programme aufrufen, den Eintrag vom Mailprogramm markieren und dann im oberen Bereich den Button Ändern klicken. In der Regel sollte nun die Option Reparieren mit angeboten werden.

Ist auch dieser Schritt nicht die finale Lösung, bitte die Datei lxmailcom.dll nachregistrieren. Wie dies funktioniert, habe ich hier in einem älteren Artikel schon einmal beschrieben.

[Update 1]Ein weiterer Lösungsweg: prüft in der Registry im Pfad HKLM\SOFTWARE\Microsoft\Windows Messaging Subsystem beim Eintrag MAPI ob dort der Wert 1 hinterlegt ist.

Registrywert MAPI prüfen

Bei 64bit-Systemen/Anwendungen bitte im Pfad HKLM\SOFTWARE\WOW6432Node\Microsoft\Windows Messaging Subsystem die oben aufgeführte Anpassung vornehmen.

Wichtig: Eingriffe und Änderungen in der Registry können schwerwiegende Folgen auf die Funktionalität Eures PCs haben. Bitte nur durchführen, wenn entsprechende Sicherheit im Umgang in diesem Bereich vorhanden, oder an geeignetes Fachpersonal wenden.

Allgemein noch der Hinweis: sowohl das Lexware Programm wie auch das Mailprogramm sollten nicht im Kompatibilitätsmodus ausgeführt werden. Dies könnt Ihr prüfen, wenn Ihr das Programmsymbol auf dem Desktop (oder wo auch immer Ihr es liegen habt) mit der rechten Maustaste anklickt, Eigenschaften im sich öffnenden Kontextmenü auswählt und dort den Reiter Kompatibilität wählt. Hier sollte kein Haken bei Programm im Kompatibilitätsmodus ausführen für gesetzt sein.

Für diejenigen unter Euch, die die aktuelle Thunderbid-Version im Einsatz haben: prüft bitte, ob Ihr alle Windows Updates installiert habt, auch die optionalen. Hierzu die Windows Update Funktion aufrufen, nach Updates suchen lassen und die angebotenenen installieren.

[Update 2] Ausserdem kann es sein, dass in der Registry falsche Einträge hinterlegt sind. Prüft zunächst, ob in den Standard-Apps Einstellungen das passende Mailprogramm ausgewählt ist. Passt das, aber der Mailversand klappt noch immer nicht, schaut bitte in der Registry wie nachstehend beschrieben nach.

Unter HKCU\Software\Clients\Mail und HKLM\Software\Clients\Mail schauen, was dort als Client eingetragen ist. Ist dort etwas anderes hinterlegt, als Ihr als Standardmailprogramm nutzt bzw. nutzen wollt, muss der Eintrag geändert werden.

Registryeintrag E-Mail Standard Client

Um einen Eintrag zu ändern klickt Ihr den REG_SZ Schlüssel mit der rechten Maustaste an und wählt ändern. Anschliessend tragt Ihr im Feld Wert die korrekte Bezeichnung ein. Als Name bitte immer die Bezeichnung so eintragen, wie das Mailprogramm unter HKLM\Software\Clients\Mail in den darunter liegenden Registrypfaden bezeichnet wird.

[Update 3] Eine weitere Ursache kann sein, dass Ihr das Mailprogramm in einer 64bit Version installiert habt. Speziell bei Thunderbird hat eine Umstellung auf die 32bit Version zum Erfolgt geführt. Bei anderen Mailprogrammen kann dies ebenso eine Möglichkeit sein, welche Ihr in Erwägung ziehen solltet.

Ich freue mich, wenn einer der obigen Punkte bei Euch zur Lösung des Sachverhaltes führt und die Nachrichten nun wieder erfolgreich versandt werden können. Feedback dazu gern in die Kommentare. Für konkrete Fragen oder Supportthemen bitte rüber in die Community wechseln in dazu ein neues Thema eröffnen.

[trinkgeld]

letzte Bearbeitung: 2020-09-28