In den letzten Tagen treten etwas vermehrt die Meldungen in Foren auf, dass der E-Mail Versand aus den Lexware faktura+auftrag bzw. warenwirtschaft Programme nicht mehr funktioniert.

Fehlermeldung / Error

Im konkreten Beispiel melden AnwenderInnen, dass beim Versuch eine E-Mail aus dem Programm heraus zu versenden, eine Meldung ohne Text, jedoch mit gelbem Ausrufezeichen erscheint, wie im nachstehenden Screenshot:

gelbes Ausrufezeichen Lexware Mailversand

Bei Nutzung der „E-Mail an„-Funktion gibt es bei einem anderen Anwender das Problem mit der Meldung wie in nachstehendem Screenshot:

E-mail Versand Lexware Meldung E-mail an

Diese Problematik entsteht oftmals, wenn auf dem PC ein RegCleaner (Tool zur Bereinigung der Registrierungsdatenbank von Windows)  läuft. Ich persönlich mag solche Tools (ebenso allgemein „Tuning“-Tools) überhaupt nicht. Schon gar nicht, wenn selbige automatisch und unkontrolliert im Hintergrund laufen. Diese machen oftmals mehr Ärger statt zu helfen.

Lösungsansatz

Um den Mailversand wieder funktionsfähig zu bekommen, ist die manuelle Nachregistrierung von .dll-Dateien notwendig. Ich beschreibe nachstehend den Ablauf.

Bitte beachtet hierbei aber, dass Ihr dies nur ausführen solltet, wenn Ihr wisst, was Ihr tut und Euch sicher damit fühlt.

Wenn Ihr Euch hier eher unsicher seid, dann wendet Euch an Eure EDV-Betreuung, einen der regionalen Lexware Partner oder optional auch via Support-Formular an mich.

Schritt 1 a (unter Windows Vista / 7)

Unter Windows Vista und Windows 7: klickt auf den Windows Start-Button und gebt in das dortige kleine Suchfeld, am Ende der sich öffnenden Liste, cmd ein.

Windows Eingabeaufforderung aufrufen

Schritt 1 b (unter Windows Vista / 7)

Klickt dann mit der rechten Maustaste auf den Treffer cmd.exe:

Windows Eingabeaufforderung aufrufen

Schritt 1 c (unter Windows Vista / 7)

Wählt dann Als Administrator ausführen:

Windows Eingabeaufforderung aufrufen

Schritt 1 a (Windows 8 / 8.1 / 10)

Unter Windows 8/8.1 bzw. Windows 10 klickt mit der rechten Maustaste auf das Windows Symbol. Es öffnet sich die im nachstehenden Screenshot dargestellte Liste.

Windows Eingabeaufforderung aufrufen

Schritt 1 b (Windows 8 / 8.1 / 10)

Hier wählt Ihr Eingabeaufforderung (Administrator).

Schritt 2 (Vista / 7 / 8 / 8.1 / 10)

Die Abfrage, ob Ihr wollt, dass das Programm Änderungen am Computer vornimmt, bestätigt Ihr mit Ja:

Windows Sicherheitsmeldung

Schritt 3 (Vista / 7 / 8 / 8.1 / 10)

Es öffnet sich nun die Eingabeaufforderung mit dem Pfad C:\Windows\System32>

Windows Eingabeaufforderung aufrufen

Schritt 4 (Vista / 7 / 8 / 8.1 / 10)

Hier gebt Ihr dann den Befehl und Pfad cd C:\Program Files (x86)\Common Files\Lexware\Dll ein (es handelt sich um kleine L, nicht grosse I). Solltet Ihr noch ein 32bit Betriebssystem nutzern, ist der Pfad nach dem cd Befehl: C:\Program Files\Common Files\Lexware\Dll

Windows Eingabeaufforderung aufrufen

Schritt 5 (Vista / 7 / 8 / 8.1 / 10)

Nach Druck auf Enter wird dann in den entsprechenden Pfad gewechselt:

Windows Eingabeaufforderung aufrufen

Schritt 6 (Vista / 7 / 8 / 8.1 / 10)

Als nächstes gebt Ihr Regsvr32 lxmailcom.dll ein:

Windows Eingabeaufforderung aufrufen

Schritt 7 (Vista / 7 / 8 / 8.1 / 10)

Nachdem Ihr Enter drückt, sollte die nachstehende Meldung erscheinen, mit welcher die Registrierung quittiert wird.

Windows Eingabeaufforderung aufrufen

Schritt 8 (Vista / 7 / 8 / 8.1 / 10)

Im Anschluss gebt Ihr Lxmailcomsrv.exe /regserver ein und drückt wieder Enter:

Windows Eingabeaufforderung aufrufen

Schritt 9 (Vista / 7 / 8 / 8.1 / 10)

Dann könnt Ihr das Eingabeaufforderungs-Fenster schliessen.

Der E-Mail Versand aus dem Lexware Programm heraus sollte nun wieder wie gewünscht funktionieren.

Nochmal der Hinweis: bitte diese Schritte nur durchführen, wenn Ihr Euch sicher damit fühlt. Bitte auch genau die Eingaben prüfen ob alles korrekt eingegeben wurde, bevor Ihr auf Enter drückt.

Die Lösung hilft bei einem einigen der möglichen Probleme im Hinblick auf den Mailversand aus dem Programm heraus. Es ist jedoch nicht die Pauschallösung für alle Ursachen. Solltet Ihr einen anderen Sachverhalt vorliegen haben oder diese Vorgehensweise bei Euch nicht zum Erfolg führen, dann nutzt die Community.

Sollte es funktionieren und Ihr wieder versenden können, gern unten in den Kommentaren Feedback da lassen. 🙂

Sollte bei Euch ein RegCleaner (und/oder anderes „Tuning“-Tool) laufen, empfehle ich, selbige(s) zu deinstallieren.

[Update 2018-06-12] Evtl. helfen bei dem Sachverhalt auch Hinweise aus einem aktuelleren Artikel zur Meldung „Nachricht konnte nicht versendet werden„.[/]


Dir hat der Artikel weitergeholfen? Das freut mich. Du kannst gern etwas Trinkgeld
in den Hut werfen, wenn Du magst und lex-blog.de damit unterstützen. Vielen Dank. <3

Screenshots Fehlermeldungen: Forum, restliche lex-blog

letzte Bearbeitung: 2018-06-12